Deploying Cisco Switch Initial Configuration – SECNET E1

775

Deploying Cisco Switch Initial Configuration

In this video I will be going over the initial configuration of a Cisco Catalyst 2960 48 port switch. This video is the first episode for the new SECNET series in which I will be posting the build and configuration of an end-to-end enterprise network.

Please note this video will cover just the initial configuration of the Cisco Catalyst 2960 Switch. Additional configuration for AAA, NTP, DNS, 802.1x etc will be configured throughout the series.

Building configuration...

Current configuration : 8721 bytes
!
! Last configuration change at 01:23:16 UTC Mon Mar 1 1993 by ladmin
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname sw1
!
boot-start-marker
boot-end-marker
!
!
username ladmin privilege 15 secret 5 <!NO!>
no aaa new-model
switch 1 provision ws-c2960s-48ts-l
!
!
ip domain-name secnetwork.org
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
ip ssh maxstartups 2
ip ssh version 2
!
!
!
!
!
interface Port-channel1
 description Firewall Uplink
 switchport trunk native vlan 5
 switchport trunk allowed vlan 11,21,31,41,51,61,100,666
 switchport mode trunk
 spanning-tree portfast trunk
!
interface FastEthernet0
 no ip address
!
interface GigabitEthernet1/0/1
 description Firewall Uplink
 switchport trunk native vlan 5
 switchport trunk allowed vlan 11,21,31,41,51,61,100,666
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
!
interface GigabitEthernet1/0/2
 description Firewall Uplink
 switchport trunk native vlan 5
 switchport trunk allowed vlan 11,21,31,41,51,61,100,666
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
!
interface GigabitEthernet1/0/3
 description Firewall Uplink
 switchport trunk native vlan 5
 switchport trunk allowed vlan 11,21,31,41,51,61,100,666
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
!
interface GigabitEthernet1/0/4
 description Firewall Uplink
 switchport trunk native vlan 5
 switchport trunk allowed vlan 11,21,31,41,51,61,100,666
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
!
interface GigabitEthernet1/0/5
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/6
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/7
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/8
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/9
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/10
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/11
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/12
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/13
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/14
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/15
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/16
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/17
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/18
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/19
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/20
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/21
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/22
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/23
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/24
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/25
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/26
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/27
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/28
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/29
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/30
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/31
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/32
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/33
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/34
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/35
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/36
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/37
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/38
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/39
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/40
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/41
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/42
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/43
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/44
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/45
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/46
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/47
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/48
 description Management Laptop
 switchport access vlan 11
 switchport mode access
!
interface GigabitEthernet1/0/49
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/50
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/51
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/52
 description DISABLED
 switchport access vlan 999
 switchport mode access
 shutdown
!
interface Vlan1
 no ip address
!
interface Vlan11
 description SW1 MGT Interface
 ip address 10.0.11.11 255.255.255.0
!
ip default-gateway 10.0.11.1
no ip http server
no ip http secure-server
!
logging esm config
banner login ^C
############################################################################
#                                                                          #
# If you are not authorized to access this system, exit immediately.       #
# Unauthorized access to this system is forbidden by company policies,     #
# national, and international laws. Unauthorized users are subject to      #
# criminal and civil penalties as well as company initiated disciplinary   #
# proceedings. By entry into this system you acknowledge that you are      #
# authorized access and the level of privilege you subsequently execute on #
# this system. You further acknowledge that by entry into this system you  #
# expect no privacy from monitoring.                                       #
#                                                                          #
############################################################################
^C
!
line con 0
 logging synchronous
 login local
line vty 0 4
 logging synchronous
 login local
 transport input ssh
line vty 5 15
 logging synchronous
 login local
 transport input ssh
!
end

LEAVE A REPLY

Please enter your comment!
Please enter your name here

This site uses Akismet to reduce spam. Learn how your comment data is processed.